This project is read-only.

installing nerddinner on webhotel

Dec 22, 2011 at 10:39 AM
Edited Dec 24, 2011 at 1:44 AM

Hi everyone!
I have just downloaded the latest nerddinner 2.0 (Change Set: 48637) (22. december 2011) and opened it in visual studio, I have tried to run it in localhost, and everything is working fine, all subpages, creating a dinner etc. 

I have then tried to publish the project using the visual studio built in pusblishing wizard. I'm publishing to a local folder on C drive (just files needed by the site). Hereafter I upload everything inside this folder on to a webhotel that is the root of a webhotel.

When I go to my domain name (hosted on a IIS 7 ( 4)) and have a look at it, then everything looks fine, however all subpages does not work. When I click on "log on", "host a dinner" or "about" links or any other link, I receive a 404 error page:

HTTP Error 404.0 - Not FoundThe resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

I have not changed anything within the config files, ConnectionStrings.config and web.config. 

Am I missing somehing?

Dec 24, 2011 at 1:55 AM
Edited Dec 24, 2011 at 1:59 AM

The solution

My webhotel was running IIS 7.0 in classic mode, so I changed it to integrated mode. Now it's working :)

P.S. I got the solution from: